This topic contains 2 replies, has 2 voices, and was last updated by  julian_s 2 months ago.

PHP7 Compatibility Failure

  • There are a couple of issues with the theme that prevents usage with PHP7:

    FILE: /www/wp-content/themes/richer/framework/importer/importer.php
    ————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————–
    219 | ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
    ————————————————————————————————–

    FILE: /www/wp-content/themes/richer/framework/importer/wordpress-importer.php
    ———————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————
    66 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————

    Hello, anyone going to respond to this? I’ll wait another week and then I’m going to have to adjust my rating of the theme since you’re not responsive.

    I am having the same issue. Please upgrade this theme so it PHP 7.0 compatible. Thanks Julian

You must be logged in to reply to this topic.